Omni

Electronic Autoharp

Requirements

To use the Omni presets you will need a copy of Ableton Live.

The presets were made in Live version 9.7 so you will need this version or higher.

The pack will work with all editions of Live including Live Intro & Live Lite.

Scroll to Top